adsense



[cocos2d-x] The "android" command is deprecated.

3.14 이전 버전에서 cocos compile을 시도하면 제목과 같은 오류가 나면서 진행할 수 없게 됩니다.
대충 검색해보니까 4월에 발생한 이슈네요.
보름 전까지만 해도 빌드 잘돼서 엥 했는데, sdk tools를 업데이트 안하고 있어서였던 듯.

sdk tools가 버전업되면서 일어난 현상으로,
아래 링크의 다운로드를 받아 안드로이드 sdk가 설치된 폴더의 tools 폴더를 압축 안에 있는 것으로 변경하면
일단은 해결됩니다.
일단은..
(왜 이리 불길하게 얘기하냐면 개발툴이 정규 업그레이드를 제대로 소화 못해서 구버전이랑 섞어쓰게 되는건 영 질색이라)

안드스튜에서 apk 빌드 시 ndk 컴파일이 같이 진행되는 3.15 이상에서는 확인해보지 못했습니다.
3.15는 action이 무작위적으로 멈추는 버그가 있어서 개인적으로는 건너 뛸 생각입니다. 3.16 예고도 나왔으니..



구버전 sdk tools 다운로드 :

윈도우용
https://dl.google.com/android/repository/tools_r25.2.5-windows.zip

리눅스용
https://dl.google.com/android/repository/tools_r25.2.3-linux.zip

덧글

  • 펭귄대왕 2018/04/12 15:48 # 답글

    ※) GoogleSignInClient로 재편된 구글 게임서비스 api를 사용하려면 sdk tools를 27.0.* 이상으로 올려야 합니다.
    그리되면 android 커맨드는 쓸 수 없으므로 cocosd-x도 강제(?) 업그레이드행..
    이 추가사항이 입력되는 시점 기준으로, 3.16을 권장합니다.

    GoogleSignInClient API가 구현도 편하고 직관성도 훨씬 좋습니다..
댓글 입력 영역
* 비로그인 덧글의 IP 전체보기를 설정한 이글루입니다.


Books

Geek라이프

게임 매니악스 슈팅 게임 알고리즘
마츠우라 켄이치로,츠카사 유키 공저/손정도 역/박민근,Pope Kim 감수

게임 매니악스 퍼즐 게임 알고리즘
마츠우라 켄이치로,츠카사 유키 공저/김병국 역

만들면서 배우는 유니티 게임 프로그래밍
송용성 저

핵심강좌! Cocos2d-x
이재환 저

될 수 있어! SE 8
나츠미 코지 저/Ixy 그림/김경훈 역
예스24 | 애드온2